Please be advised of the following scheduled maintenance:
Scheduled for October 19, 2025 at 3:00 AM – 5:00 AM
Affects
EncryptTitan Access Management Portal
Under maintenance from 3:00 AM to 5:00 AM
EncryptTitan Secure Portals
Under maintenance from 3:00 AM to 5:00 AM
EncryptTitan NA Region Secure Message Portal
Under maintenance from 3:00 AM to 5:00 AM
EncryptTitan EU Region Secure Message Portal
Under maintenance from 3:00 AM to 5:00 AM
EncryptTitan DE Region Secure Message Portal
Under maintenance from 3:00 AM to 5:00 AM
EncryptTitan Encryption Gateways
Under maintenance from 3:00 AM to 5:00 AM
Completed
October 19, 2025 at 5:00 AMCompleted
October 19, 2025 at 5:00 AMMaintenance has completed successfully
In progress
October 19, 2025 at 3:00 AMIn progress
October 19, 2025 at 3:00 AMMaintenance is now in progress
Planned
October 19, 2025 at 3:00 AMPlanned
October 19, 2025 at 3:00 AMAffected Services
· Network connectivity
Affected Users / Customers
· Customers utilizing Encrypt Titan services.
Expected Impact
· Brief periods of increased latency or packet loss may occur during de-peering and re-peering.
· No significant service interruption is expected.
Reason for Maintenance
· One of our upstream network providers will be performing required maintenance.
· To minimize customer impact, our engineers will proactively de-peer from this provider and re-peer once the maintenance is complete.
Actions Required
· No action is required from customers.