EncryptTitan - Unintended Message Encryption Event being report by some customers. – Incident details

Unintended Message Encryption Event being report by some customers.

Resolved
Operational
Started 11 months agoLasted about 3 hours

Affected

EncryptTitan Encryption Gateways

Operational from 4:25 PM to 7:10 PM

EncryptTitan NA Region Encryption Gateways

Operational from 4:25 PM to 7:10 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    We have identified the issue, and are working to empty the remaining EncryptTitan mail queues.

  • Investigating
    Investigating
    We are currently investigating this incident.