EncryptTitan - An email processing issue has been detected in the EncryptTitan EU Region Encryption Gateways. – Incident details

An email processing issue has been detected in the EncryptTitan EU Region Encryption Gateways.

Resolved
Operational
Started about 1 month agoLasted about 3 hours

Affected

EncryptTitan EU Region Encryption Gateways

Major outage from 7:56 PM to 11:09 PM

Updates
  • Resolved
    Resolved

    EncryptTitan Engineers have mitigated a packet loss issue related to an IP provider for our EU region encryption gateways.

    ET Gateways have processed all queued messages and are functioning normally.

  • Investigating
    Investigating

    Customers, utilizing the European Union EncryptTitan Gateways are impacted. The Secure Portal System is not impacted.

    We are currently investigating this incident.