EncryptTitan - An email processing issue has been detected in the EncryptTitan US Region Encryption Gateways. – Incident details

An email processing issue has been detected in the EncryptTitan US Region Encryption Gateways.

Resolved
Operational
Started 15 days agoLasted about 2 hours

Affected

EncryptTitan US Region Encryption Gateways

Operational from 6:20 PM to 8:10 PM

Updates
  • Resolved
    Resolved

    Please be aware that messages were delayed for an average of 25 - 40 minutes during this event. However, a small percentage of message may have been delayed over an hour.

    We greatly apologize for this incident and thank you for your patience.

  • Identified
    Identified

    We have identified the email processing issue and have fully mitigated the cause. Email queues are back up to normal processing speed and we estimating that any queued messages will be delivered within the next 20 minutes.

  • Investigating
    Investigating
    We are currently investigating this incident.