EncryptTitan - Cloudflare's work around remains in place and operational. – Incident details

Cloudflare's work around remains in place and operational.

Resolved
Operational
Started 9 days agoLasted 2 days

Affected

EncryptTitan Access Management Portal

Major outage from 3:24 PM to 5:08 PM, Operational from 5:08 PM to 10:03 PM

EncryptTitan Secure Portals

Major outage from 3:24 PM to 5:08 PM, Operational from 5:08 PM to 10:03 PM

EncryptTitan NA Region Secure Message Portal

Major outage from 3:24 PM to 5:08 PM, Operational from 5:08 PM to 10:03 PM

EncryptTitan EU Region Secure Message Portal

Major outage from 3:24 PM to 5:08 PM, Operational from 5:08 PM to 10:03 PM

EncryptTitan DE Region Secure Message Portal

Major outage from 3:24 PM to 5:08 PM, Operational from 5:08 PM to 10:03 PM

EncryptTitan Encryption Gateways

Major outage from 3:24 PM to 5:08 PM, Operational from 5:08 PM to 10:03 PM

Updates
  • Update
    Update

    Cloudflare has discovered IP address inconsistencies between our mapped Cloudflare IP addresses, and the IP addresses assigned by their network as DNS resolvers for encrypttitan.net.

    The discrepancies caused the CloudFlare network to automatically designate the EncryptTitan domain as "moved" (from Cloudflare's network) on 4 different occasions causing DNS outages.

    Although Cloudflare has not determined why the discrepancy existed between the IP database and our network configuration, they have stated it has been resolved for our zone.

    We deeply apologize for the resent DNS issues and for any distress it has caused.

    Thank you,

    Encrypt Titan Support Team

  • Resolved
    Resolved

    I'm afraid we do not have any further updates to share at the moment, the Cloudflare Engineering team is still working to identify the core issue.

    Cloudflare's work around remains in place and operational.

    Thank you for your patience as we continue monitoring to ensure that the EncryptTitan remains optimal.

  • Update
    Update

    I'm afraid we do not have any further updates to share at the moment, the Cloudflare Engineering team is still working to identify the core issue.

    Cloudflare's work around remains in place and operational.

    Thank you for your patience as we continue monitoring to ensure that the EncryptTitan remains optimal.

  • Monitoring
    Monitoring

    The "stop gap" that the Cloudflare's Global Engineering Team provided for DNS resolutions has been working as expected and we have not seen any mail flow issues.

    We will continue to monitor this incident and provide updates as information becomes available.

  • Identified
    Identified

    DNS queries are being processed.

    However, we have not received an update from Cloudflare, other than that they have escalated it to the Global Engineering Team and it has been categorized at the highest urgency.

    We will continue to monitor the situation.

    We apologize for this issue and will update this ticket one we have an update.

  • Investigating
    Investigating

    We are currently working with CloudFlare to resolve this issue.